User Manual
11/6/2019

Illinois Department of Transportation
Bureau of Design
District 1
Region 1
Table of Contents

1. Defining Geometric Design in CADD................................................................. 4

2. Creating Design Points ..................................................................................... 4
   2.1 Creating a new survey field book in Project Explorer .................................. 4
   2.2 Renaming field book ................................................................................... 4
   2.3 Modifying point display (Optional) ............................................................... 4
   2.4 Placing design points .................................................................................. 5
      2.4.1 Inputting design point properties ......................................................... 5
      2.4.2 Placing proposed dummy design point ............................................... 5
      2.4.3 Placing proposed design points ......................................................... 6
      2.4.4 Modification of proposed design points (as needed) ......................... 6
   2.5 Inputting existing elevations of proposed design points ............................. 6
      2.5.1 Creating elevation labels (existing points only) .................................... 6
      2.5.2 Inputting existing elevation into design points ..................................... 7

3. Exporting Design Points into ADA Automation Tool ......................................... 7
   3.1 Selecting design points .............................................................................. 7
   3.2 Generating a point report ........................................................................... 8
   3.3 Exporting report in .xls format .................................................................... 8
   3.4 Copying report data into ADA Automation Tool spreadsheet ....................... 9

   4.1 Renaming template sheet ........................................................................... 10
   4.2 Listing design points in Table 1 ................................................................. 10
   4.3 Listing design segments in Table 2 ............................................................. 11
   4.4 Defining types of segment in Table 2 ......................................................... 11
   4.5 Overwriting maximum and minimum slope in Table 2 (as needed) ............ 12
   4.6 Defining slope direction in Table 2 (as needed) ......................................... 12
1. Defining Geometric Design in CADD
   Define geometric design in MicroStation utilizing BDE and PROWAG design guidelines and standards.

2. Creating Design Points
   Design points are created for the proposed design at each node using the following steps:

   2.1 Creating a new survey field book in Project Explorer
   File -> Project Explorer -> Survey Tab -> right click on Field Books -> New.

   2.2 Renaming field book
   Right click on new Field book -> Properties -> enter new name in the name property field.

   2.3 Modifying point display (Optional)
   Turn on levels TOPO_POINT SPC CELL and TOPO_POINT NUMBERS.
   Modify point annotation to only display point name by right clicking on All Point Features -> Annotation -> selecting on/off properties to be displayed.
2.4 Placing design points

Open the New Point Feature Toolbox by:
Right click on All Point Features -> New.

2.4.1 Inputting design point properties

Select the newly created field book from drop down menu -> Set the feature definition to 293 -> Create a 5-character name unique to this corner -> Set Control point to False -> Set Terrain Model Attribute to Spot. Continue to next step without exiting any tools, i.e., don’t right-click.

NOTE: It is imperative for the name to be 5-characters in length. No more, no less.

2.4.2 Placing proposed dummy design point

Click through the prompts until a point and elevation appears highlighted in yellow -> click somewhere outside of the sidewalk area to create the dummy point. Continue to next step without exiting any tools.
2.4.3 Placing proposed design points

Continue placing rest of points at nodes of proposed geometric design. Each point, by default, will be assigned a corresponding number following the name and an _.

To simplify later steps, abide by some point-placement convention where, for example, the adjacent points are placed in the direction where the proposed elevation will descend.

2.4.4 Modification of proposed design points (as needed)

Move points by clicking on the point and selecting the center handle. Rename points by going into element information of the point and entering a new name.

2.5 Inputting existing elevations of proposed design points

2.5.1 Creating elevation labels (existing points only)

Use the Label Terrain Spots tool, under the Civil Tools task tab -> Terrain Model. Select the existing terrain model when prompted -> Click on the existing design point -> Click to place label.
2.5.2 Inputting existing elevation into design points

Open element information window for the point "Enter the elevation, placed using the label, into the elevation field.

3. Exporting Design Points into ADA Automation Tool

Data for points created is extracted from CADD and imported into ADA Automation Tool using the following steps:

3.1 Selecting design points

Select all elements in the corner to-be-designed "turn off selection for all elements not in the grey TOPO_POINT SPC CELL level. NOTE: End-result of selection should only include points created."
3.2 Generating a point report

With points selected use the Point Feature Station Offset Elevation Report tool, found under Civil Tools task tab → Analysis & Reporting. Follow prompts by selecting any base line that runs through the project → left-click to create report. A report will open. If a base line, like an alignment, is not available, create one using Line Between Points tool under Civil Tools → Horizontal Geometry.

3.3 Exporting report in .xls format
Set report format to: StationOffsetNorthingEastingElevationFeature from the left sidebar. Format of the report needs to match that shown in sub-steps 3.2 and 3.3. It can be modified through Tools -> Format Options. Then, click File -> Save as. Save file in XLS (excel) format somewhere in your project folder.

NOTE: it is recommended to name the exported excel file after the corner name, i.e., 5-character name.

3.4 Copying report data into ADA Automation Tool spreadsheet

Copy the 7-column block from the report Excel Sheet into the first seven columns of the CADD_DATA tab in the ADA_Automation_Tool spreadsheet. Note that all points in the CADD_DATA tab need to be unique. To overwrite a point that is already in the CADD_DATA sheet with a new location, either copy the point row from the MicroStation exported excel into the CADD_DATA tab over the point to be replaced, or simply overwrite all points in the same manner. New points can be added in the same way.
4. Generating Proposed Design Using ADA Automation Tool

Data for proposed design is generated utilizing an algorithm applied in the ADA Automation Tool in the form of a spreadsheet using the following steps:

4.1 Renaming template sheet

After copying data extracted from CADD to the CADD_DATA tab, first step is to rename the 3rd tab after the corner to be designed using the same 5-character name assigned during Step 2 Creating Design Points.

4.2 Listing design points in Table 1

In Table 1 under column B, list all points of the proposed design using their numbers (or letters if changed in CADD to letters). Proposed points are to be listed in rows 3 to 45, and existing points are to be listed in rows 47 to 71.
4.3 Listing design segments in Table 2

In Table 2 under columns H and I, list all segments of the proposed design. Proposed segments are to be listed in rows 3 to 45. It is optional to listed existing segments in rows 47 to 71. Length, slope and elevation difference will automatically populate.

NOTE: in Table 1 and 2 under columns A and E, duplicate entries are pointed out through a red highlight. Points and segments must be unique.

4.4 Defining types of segment in Table 2

The maximum and minimum slope under columns N and O are used by the algorithm as constraints to generate the proposed design. These slopes are determined by the type listed under column J, any slope overrides under column K and L, and slope direction if defined under column M.

Under column J, define the type of each segment. Types will determine the allowable slope range for each segment as defined in the Category table under columns X, Y, and Z.
4.5 Overwriting maximum and minimum slope in Table 2 (as needed)

In TABLE 2, under columns K and L, overwrite allowable slope range for individual segments as needed.

4.6 Defining slope direction in Table 2 (as needed)

In Table 2, under column M, define slope direction for segments. For example, a segment from 1 to 2 with a slope direction of + indicates that the calculated slope will go up from 1 to 2. Accordingly, a segment from 1 to 2 with a slope direction of - indicates that the calculated slope will go down from 1 to 2. Moreover, if slope direction is left blank, it can go either up or down.
4.7 Running optimization algorithm

Click the CALCULATE button under columns X, Y, and Z to generate the design. An algorithm is applied attempting to generate elevations for the proposed design that are within allowable slope ranges specified by user. This algorithm is limited to 40 iterations to save time. The OPTIMIZE button will continue the iteration process from the 40th iteration onward.

Slopes calculated using generated proposed elevations will either not be highlighted, highlighted in red, or highlighted in yellow. A red highlight is an indication that the slope is outside slope range specified by user due to rounding error. A yellow highlight is an indication that the slope is outside slope range specified by user due to feasibility or seeding problem. No highlight indicates slope is within range. NOTE: it’s worth mentioning that the shorter the segment the larger the rounding error.

A message is displayed between the CALCULATE and OPTIMIZE buttons indicative of design status.

4.7.1 Seeding problem

Simply, problem due to seeding can be ruled out by clicking on CALCULATE multiple times, provided after the each run the design violates specified slope ranges. Every time the CALCULATE button is clicked a random seed, i.e., elevations within the range of existing elevations, is used as a starting point for all elevations in the algorithm. Some random seeds are worse than others leading to the violation of specified slope ranges in some cases. The probability of having a “bad” random seed is about 50% so by running the algorithm multiple times the user can be confident that the violation of slope ranges is NOT due to a bad seed rather, due to feasibility. A random seed for a starting point is also the reason why the user might come across a case where multiple generated proposed designs meeting user specified slope ranges have different proposed elevations. However, if the design meets user specified slope ranges that’s all that matters.
4.8 Extracting data from ADA Automation Tool

4.8.1 Extracting design data in .txt format

Table 3. under columns BA to BD, is an output table for plan-preparation purposes available with proposed design information.

Table 3. OUTPUT

<table>
<thead>
<tr>
<th>Point</th>
<th>Station</th>
<th>Offset</th>
<th>Elevation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>051.34</td>
<td>-38.42</td>
<td>623.51</td>
</tr>
<tr>
<td>2</td>
<td>096.67</td>
<td>-40.21</td>
<td>623.45</td>
</tr>
<tr>
<td>3</td>
<td>096.95</td>
<td>-47.18</td>
<td>620.43</td>
</tr>
<tr>
<td>4</td>
<td>050.84</td>
<td>-55.08</td>
<td>622.02</td>
</tr>
<tr>
<td>5</td>
<td>056.32</td>
<td>-52.75</td>
<td>617.12</td>
</tr>
<tr>
<td>6</td>
<td>052.23</td>
<td>-55.99</td>
<td>612.02</td>
</tr>
<tr>
<td>7</td>
<td>075.09</td>
<td>-23.60</td>
<td>626.67</td>
</tr>
<tr>
<td>8</td>
<td>076.07</td>
<td>-25.24</td>
<td>626.57</td>
</tr>
<tr>
<td>9</td>
<td>061.38</td>
<td>-24.84</td>
<td>626.02</td>
</tr>
<tr>
<td>10</td>
<td>056.89</td>
<td>-45.90</td>
<td>622.22</td>
</tr>
<tr>
<td>11</td>
<td>063.17</td>
<td>-44.80</td>
<td>621.03</td>
</tr>
<tr>
<td>12</td>
<td>048.81</td>
<td>-51.80</td>
<td>621.89</td>
</tr>
<tr>
<td>13</td>
<td>049.19</td>
<td>-52.26</td>
<td>621.03</td>
</tr>
<tr>
<td>14</td>
<td>028.82</td>
<td>-68.30</td>
<td>621.99</td>
</tr>
<tr>
<td>15</td>
<td>052.54</td>
<td>-45.46</td>
<td>621.26</td>
</tr>
</tbody>
</table>

CADD_DATA tab under column I is populated automatically with proposed design information. Once the proposed design is determined compliant, information is ready to be copied out to a .txt file format as will be explained in the next step (Step 5).

4.8.2 Extracting plan preparation data

Table 3. OUTPUT

<table>
<thead>
<tr>
<th>Point</th>
<th>NORTING</th>
<th>EASTING</th>
<th>ELEVATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>2</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>3</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>4</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>5</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>6</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>7</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>8</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>9</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>10</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>11</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>12</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>13</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>14</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>15</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>16</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>17</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>18</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>19</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
<tr>
<td>20</td>
<td>1072714</td>
<td>22</td>
<td>625.51</td>
</tr>
</tbody>
</table>

Through a drop-down menu, STATION and OFFSET can be changed to NORTING and EASTING, as needed.
5. Importing Design Points from ADA Automation Tool into CADD

Data for proposed design is exported from ADA Automation Tool and imported into CADD using the following steps:

5.1 Saving extracted data

As briefly mentioned in sub-step 4.8.1, CADD_DATA tab under column I has proposed design information ready to be imported into CADD after it is copied into a .txt file format.

5.2 Importing extracted data into CADD

Once .txt file is saved, next step is importing the .txt file into CADD. This is done by dragging the .txt file and dropping it in the Project Explorer under Field Books.

If a .txt file already exists for the same corner in the Field Book, delete it before importing the .txt file into CADD.

Once dropped, prompts will ask for format and override options. The format must be IDOT D1-Comma-PtNumNEZCodeCode. Then override all.
5.3 Creating a terrain model

Once data is imported into CADD, next step is to create a terrain from imported data. This is done by clicking on Project Explorer -> right click on Field Books -> Create Terrain Model. The terrain model should show as seen in second image above. If the terrain doesn’t show, check if Terrain EX level and Terrain Ex Exterior are turned on.

If a Terrain Model already exists for the Field Book in Project Explorer under Terrain Models in the Civil Model tab, delete the Terrain Model and recreate it using data imported to the Field Book.

5.3.1 Overwriting imported data

To overwrite the imported data, one must delete the .txt file in Project Explorer under Field Books in the Survey tab. In addition, the terrain must be deleted in Project Explorer under Terrain Models in the Civil Model tab.
5.4 **Modify Design (as needed)**

The design can be modified by adding, removing or relocating design points as needed using the following steps:

1. Modify geometric design
2. Create or move design points as needed to match modified design (Step 2: Creating Design Points)
3. Export points (Step 3: Exporting Points into ADA Automation Tool)
4. Overwrite all points (in CADD_DATA tab of ADA Automation Tool)
5. Update design points and segments (in redesigned corner tab of ADA Automation Tool)
6. In CADD, delete text file and terrain model in Project Explorer (as they will be replaced/recreated)

![Project Explorer](image)

7. Import points into CADD and recreate the terrain model (Step 5: Importing Points from ADA Automation Tool into CADD)

NOTE: cross-validate terrain model elevations with spreadsheet elevations to ensure the terrain model has updated with revised elevations.
6. Labeling Design

Labeling data for proposed design is performed in CADD using the following steps:

6.1 Labeling slopes for proposed design

Set active level to Level 47 and use the Analyze Between Points tool to create rough labels for sidewalk slopes.

The Analyze Between Points tool is located under the Civil Tools task tab -> Terrain model. Select the newly created terrain model when prompted. The terrain model is an object referenced in from the 3D model in the same file under the TERRAIN_EX and TERRAIN_EXTERIOR levels. When creating slope labels for crosswalks be sure to select the existing terrain model from the survey file instead.

Make sure nothing important is drawn in level 47 (other than slope labels) as it will be modified by a macro in the following step.

6.1.1 Cleaning up labeled slopes

Delete the extra lines and "Slope=" text by running the ADASlope macro from the D1 Blue Menu. The ADASlope macro is found under the Blue Menu -> Macros. This macro deletes all lines and arcs from level 47 and finds and replaces all "Slope=-" and "Slope=" with a blank. This step can be done manually if a macro is not available.

The formatting of the output of this tool is controlled by the active text style and Design file settings. To change the text format, select the standard Place Text tool and select the desired text style. To change the precision, go to Slope Precision option under Settings -> Design file -> Civil Formatting -> Profile Settings Tab.
6.1.2 Adjusting label location

Fine tune the location of the sidewalk slope labels as needed. This can be done by manually moving labels to desired location.

6.2 Labeling elevations for proposed design

Set the active level to an appropriate level other than level 47 and label point elevations using the Label Terrain Spots tool. The formatting of the output of this tool is controlled by the active text style, active dimension style, and the Design file settings. The text and dimension styles are controlled in the same way as the standard Place Note tool through the Label Terrain Spot Toolbox. To change the precision, go to Elevation Precision option under Settings -> Design file -> Civil Formatting -> Profile Settings Tab.

Use the Label Terrain Spots tool, under the Civil Tools task tab -> Terrain. Select the new terrain model when prompted -> Click on the existing design point -> Click to place label.
6.3 Labeling dimensions of proposed design

Dimension labeling is done using the standard Dimension Linear tool.

7. Troubleshooting

7.1 Snapping malfunction
Problem: snapping tool not functioning properly when placing newly created points (points not snapping, MicroStation crashing etc.)
Solution: turn off snaps while placing new points, then turn on snaps to modify point location.

7.2 Design point disappearance
Problem: newly created points are disappearing as they're being created.
Solution: turn off snaps while placing new points.

7.3 Design point information
Problem: point information not updating when imported into CADD.
Solution: in Project Explorer delete .txt file and terrain model. Reimport design data from ADA Automation Tool. Also, sometimes restarting MicroStation might help. As a last resort, delete the points as well as the text file and terrain model in the project explorer before reimporting the points from the text file. Be aware that doing so changes the behavior of the points. For example, now deleting the text file from project explorer will also delete the points.

7.4 Terrain display
Problem: created terrain not displaying.
Solution: use proper Feature Definition for creating points, i.e., 293, and turn on levels Terrain Ex and Terrain Ex Exterior.

7.5 Spreadsheet is slow
Problem: ADA Automation Tool is slow.
Solution: create a new copy of the file.
8. Contact Information

Ahmad Nafakh
Ahmad.Nafakh@illinois.gov
Bureau of Design
IDOT District 1

Radoslaw Rostkowski
Radoslaw.Rostkowski@illinois.gov
Bureau of Design
IDOT District 1